Google WiFi

Ask questions and give answers about computers, mobile devices, game boxes, PC security and all manner of geeky stuff.
Post Reply
User avatar
Posts: 5478
Joined: 14 Feb 2015, 15:49

Google WiFi

Post by yogi » 24 Sep 2016, 06:51

Normally I don't get too excited about new technology until I've seen it (or read reviews) out in the wild. But, when I read about this leak I immediately thought Gary with his multiplex of network devices might be interested. :mrgreen: Here's a router from Google to which you can attach other router modules to expand your network. That's not multiple networks. We are expecting one modem, one base router, and all the expansion modules you can handle attached to the base to form a single far reaching network. It's an interesting concept if nothing else. ... tober-4th/

User avatar
Posts: 3043
Joined: 16 Feb 2015, 11:54

Re: Google WiFi

Post by Kellemora » 24 Sep 2016, 12:00

Hmmm. Although I do have a WiFi router down at the house for Debi's wireless devices, everything else is hardwired.

I tried wireless a couple of times, and we found none that could reach the 150 to 200 feet up to my garage office.
We even tried placing a repeater up in the attic closest to the office, and although we did get a fairly strong signal 3 of 5 bars, it was slow and often had a long delay when doing some things. I returned it a few days after testing.

You have to be careful buying wireless routers these days, some of them have an OPEN Port for others to use outside your home. I think it was Google who started that too?

The Silver Yogi has a WiFi card, and every once in awhile I will check to see who I can see with it.
I can often see five or six routers in my area, some with 2 bars, but they are all locked of course.
But Ironically, I cannot see my own router down at the house, since I don't have the repeater anymore.

I'm a little confused about something here in this article though. I thought ALL routers could speak to other routers, or all WiFi cards could speak to other WiFi cards and routers.
Because I never trusted WiFi for security reasons, when I got the WiFi router for the frau's devices, it did not connect to the internet directly. I had it hard wired to my normal router with a different password on both devices. Then when I had to replace everything after the lightning took out most of my stuff, I just went with a DocSys 3 Router w/WiFi.

User avatar
Posts: 5478
Joined: 14 Feb 2015, 15:49

Re: Google WiFi

Post by yogi » 24 Sep 2016, 14:13

The linked article talks about rumored products that Google will release next month. The author thinks his sources are reliable, but to date I've not seen anything about the Google routers in the real world. There is a lot of black magic going on in those wireless networks and I can't say I know a lot about it, but some fundamentals do apply. A router can talk to anything with an IP address, or more specifically a MAC address. As you know from experience, routers can be linked, but it's my understanding that each router you link has it's own network ID. Thus when you do a chain of routers, each link is a separate network of it's own. You can tell a wireless router to keep quit and not broadcast who it is, but the communication is still from one net to another, so to speak. The new Google product doesn't impress me because it sounds a lot like an existing product called a bridge. In fact in your case a bridge would make more sense in that it does not have a routing table. It just bridges the traffic from one link to the next. The modules that Google will offer seem to be doing the same thing. So, I don't know what kind of groundbreaking they are doing, but then, as already mentioned, I don't know that much about wireless routers.

You're right about the risks of going wireless, but think of it like this. You can't see your router that is 150 feet away. That means nobody else can either. The eavesdropper would have to be within eyesight to see your network. I've seen routers that are over 500 feet away from home so that it all depends on the power output of the transmitter. You don't have to broadcast your ID, which means nobody will see it without a spectrum analyzer. Then again, if you do that, you will have to hard code your router information into all your network cards because they won't see the broadcast ID either. I'm not sure it's worth all the trouble for you unless you are considering an in-house cloud. If you have cloud storage at home then, of course, you want all your computers to see it. There is no more convenient way than to go wireless.

User avatar
Posts: 3043
Joined: 16 Feb 2015, 11:54

Re: Google WiFi

Post by Kellemora » 25 Sep 2016, 11:29

My frau loves having the wireless, since most of her devices are wireless.
As for me, the only wireless device I have is the little laptop I use on rare occasion to read something to the frau.
Heck even my mouse and keyboard are hardwired, while the frau uses wireless. She is a huge supporter of the battery manufacturers, hi hi...

After the hailstorm damaged my CAT5e I once again tried wireless. I paid the store for installation, because if they couldn't get it to work, they would take all their equipment back and I wouldn't be charged. So needless to say, they tried everything, including the repeater in the attic on the office side. It's less than 75 feet from the gable vent in the attic to my office.
Although I didn't tell them about it. Although the house is concrete block stucco, it has two layers of drywall on the walls and on the ceilings, and between these two layers of drywall is a paper backed aluminum foil sheet. It's not grounded, but probably blocks VHF and UHF frequencies fairly easily, although our cell phones work OK in the house.
When we couldn't get the wireless to work, I paid them to install CAT6 in place of the CAT5e, because they would have to remove and replace siding to follow the old 200 foot path of the CAT5e.

I have another question. I'm really confused about something that has to do with network printers.

From my understanding, if you have a printer on the network, you need the drivers for that printer on every computer that accesses that printer.
However, I was reading something somebody posted on how he got a printer that does not work on LInux at all, to work as a network printer. Rather than connecting the printer to the LAN, he connected it to a Windows 7 computer via USB, and shared it over the network as a shared printer. So there is no direct connection of the printer to the LAN.
The way he worded it, it sounded like if you sent a document to be printed to the shared printer, it used the Windows 7 printer driver to handle the printing, and you didn't need a printer driver on the sending computer.

Seems I tried that once and the only way I could get it to work was if I sent the document to a folder on the Windows computer, then went to that computer and opened the file on the Windows computer and then printed it. But that was a long time ago now too.

I know Windows often installs the necessary drivers for whatever printer it finds, and is why Debi accidentally sent a print job to my printer up in the office. I keep stuff stacked on my printer, and the output tray lid closed. Although it will print a single page or two without opening the lid. I'm sitting here working and suddenly my pile of stuff was pushed off my printer, knocking over my soda can and making a mess, while it printed out her four or five pages. It was plugged into the LAN but I never set up print through LAN on my computers due to no LAN drivers for that printer. I always printed through the USB cable.
By the way, I think this new printer I ordered said USB or LAN. I wonder if that means both cannot be connected at the same time?

Have a great day Yogi!

User avatar
Posts: 5478
Joined: 14 Feb 2015, 15:49

Re: Google WiFi

Post by yogi » 25 Sep 2016, 13:45

I'll start off with a little disclaimer. I never did what I am going to tell you to do. I have a better way to do it, and you may too.

The image shows the settings in my Windows 7 control panel. The settings as you see them will allow the computer to be discovered by other computers on the network. There also is a setting to allow sharing of files and printers. You could allow the Public folder to be shared, but I don't. Streaming and encryption are irrelevant in my case. I require a password to enable the sharing - I don't want my neighbors across the street to be printing on my printer, unless they have an account on it. And that is what you will need to do for people to share the print services. When an account is created for them, that effectively makes the share and they need login credentials to use the share thus created. HomeGroups are totally useless, but some people like them. I let Windows manage them, but have them turned off in the Homegroup settings.

So, in order to use the shared printer on this Windows 7 (and it may work on other flavors too) computer, you go to your network listings and look for the share (labeled as the user's account name I would presume). Click and log in. Then start printing. My best guess is that all you need to do is drag the document into the share and it will print.


To answer your question, it seems that with this arrangement only the Windows computer needs the print drivers because it effectively is acting as a print server. Obviously the client has to send the data to the printer and that may or may not require a set of drivers. if printing is truly a "shared" experience then no client drivers would be required - it's no different than saving files to an NAS, for example. Only in this case you are printing that file instead of saving it. I will admit that each time I set up a printer on any of my Linux boxes, I must install the appropriate drivers. But, the above described scenario is file sharing, not for setting up a printer per se.

Your new printer will be USB and WiFi capable. Yes, I'm reasonably certain you can set it up to do both. When you install a printer from one of your computers, you will have to select if it is a network or a USB printer. To get the functionality of both you will have to set up two print services, i.e., end up with two printer icons, one being WiFi and one being USB. You must select which one is the default, but obviously you can switch if the urge inclines you to do so.

And now for the good news. I don't recall for certain, but I think the printers you showed me have the capability to be a stand-alone Internet network print server. That makes it unnecessary for the printer to be attached to your LAN because the built in print server is attached to the Internet. Thus when your mobile device wants to print something, it sends it to the print server via the internet. No LAN, no shares, no nothing; just an Internet connection. Your printer manual will have instructions on how to do that, and all your mobile devices must have that capability as well. The interface is the Internet and the print drivers are not needed by the mobile devices - it's all done by black magic inside your Internet Print Server. :mrgreen:

User avatar
Posts: 3043
Joined: 16 Feb 2015, 11:54

Re: Google WiFi

Post by Kellemora » 26 Sep 2016, 11:37

Hi Yogi - Thank you, you are a wealth of information.

When I tried to set up the Canon Printer, it required a print driver which I tried on Linux first. The Windows computer I have up here does not have LAN because it is basically fried.

Although my new printer, the HP M477 said it was not for Windows XP, I installed it to check it out and everything worked just fine.

I purposely selected this printer because it showed it did not need QT4, which is probably a typo on hplip's page.


I did an update and upgrade before attempting the install to make sure the system was up to date. It upgraded Debian 8.5 to Debian 8.6, and the HPLIP installer is specific to version 8.5 and does not work on 8.6...
I have not updated the Silver Yogi so it was still version 8.5 and the install went perfectly, and fast too. Did not have to install anything other than running the HP installer program for this printer and OS. That's it, easy peasy!

Leaving it only as reference to the troubles I've seen.

Maybe you can help me with a problem I encountered.
I downloaded the driver package and extracted
When I ran the installer, it said it was missing two dependencies, pyqt4 and pyqt4-dbus.
Neither of these are in Synaptic.
So I downloaded PyQt-x11-gpl-4.11.4.tar.gz and extracted the PyQt-x11-gpl-4.11.4 folder.
When I went to install this package using command line, it said I needed to install a build program and SIP first.
I installed Build-Essentials from Synaptic.
Then downloaded sip-4.18.1.tar.gz and extracted the sip-4.18.1 folder.
From terminal I configured py, ran make, and in sudo ran make install, this went OK, no problems.
Then when I did the same thing to install PyQt it said I was missing two dependencies.
After a little research I found I needed to run
sudo apt-get install qt4-qmake libqt4-dev
Did this and thought all would go OK.
I rebooted to make sure everything was running, then using terminal I built the PyQt-X11-gpl-4.11.4
Make took nearly an hour to complete, and then install appeared to go OK.
I rebooted again before I ran sh
The result was the exact same error I had at the beginning. Missing pyqt4 and pyqt4-dbus dependencies.

The HP items installed and can be verified by going to the new HP logo in the top panel.
However, neither the HP setup nor CUPS can find the printer.
If I plug the printer in fresh, the computer itself recognizes a new printer is plugged in and says searching for drivers, then quits.

Neither pyqt4 or pyqt4-dbus appear in Synaptic, even after all I did to get them installed.
I do have python3-pyqt4 and python3-pyqt4-dbus but apparently the installer wants only pyqt4 and pyqt4-dbus.

I'm probably missing something simple, and just haven't figured it out yet.

Talked to my neighbor late last night, he is running Linux on one of his machines, was SUSE for awhile, now I think it is Arch. In any case, he has two HP printers, and both of them worked when he plugged them in without installing anything.
But they are just printers, not all-in-ones.

I'm sad to say, I have no idea what QT4 is other than some programming language.
Nor do I know why the installers are not placing the necessary files.

If I plug the new printer to the LAN up in my office, and install the drivers for it on my wife's computer. I don't see how that will help except for printing. I would still need SANE and other things to scan from one of the Linux computers.

I'm all ears if you have any idea of why I can't get the two missing dependencies installed.

Thank you Yogi!

User avatar
Posts: 5478
Joined: 14 Feb 2015, 15:49

Re: Google WiFi

Post by yogi » 29 Sep 2016, 09:19

Hello Gary - I must apologize for dragging my feet to reply to this. Reality has a way of taking priority over the fun things I do. I probably am not the guy you should be asking about the dependency problem because that is exactly why I think Linux is a useless invention for the common man. I've had some experiences along the lines of your current problem and have never been able to resolve the dependency issues as a patch. Invariably when this kind of thing arose I had to install the entire OS and pray it works without my inept interventions. The most frustrating experiences I've had were those when I did do a clean install and the problem remained. A search of the usual tech support forums ended up in, "gee, this looks like a problem with the latest kernel. We will have to wait until they come up with a fix." Yeah right. So much for tech support.

All rants aside I have to admire your courage. I never ran "make" unless I had explicit instruction on how to do it. Tar balls are exactly that, sticky problems. Unless you are proficient at shell programming and understand the innards of the Linux kernel being modified, you are asking for trouble by trying to add modules on your own.

But, it's only a print driver. What can go wrong? LOL My guess is that the reason you are having problems is because the developer of the printer software had them too. S/he couldn't figure it out either and decided YOU are a minority case and do not need immediate attention. HP does come out with some beautiful printer support, but they rely on GUI's that not every distro in the known universe supports. QT4 is something like Microsoft's Visual Basic wherein you can use it to link to other elements of the OS to perform a task. You need Python (or something close), however, to access QT4's functionality. Then this combination has to interact with the rest of the OS, which talks to the kernel. That's a lot of layers of complexity that need to be coordinated. What I discovered through my personal experience with this problem is that specific versions of services and drivers are needed to make some applications work. Linux developers have a habit of not making their latest spawn backwards compatible. I think that is what is happening to you. You install something that uninstalls an incompatibility. Then another part of your install breaks. So, you fix that by installing the original software and you are back to the original problem. I've been able to fix this kind of thing in Windows by only installing the print drivers and not the supporting software (that supporting software in your case is most likely what they want QT4 to do - it has little to do with the functionality of the driver per se). The risk of ignoring the GUI requirements is that HP frequently enables certain functions of it's printers (especially the AIO ones) via the GUI. Scan, for example. If you don't have the GUI, then you don't have the functionality you bought the printer for. In your case you can't install the QT4 related modules, and HP pukes. You might have to reinstall Debian x.6 if you gummed up the works too much. :cry:

My approach would be to make a virtual machine and experiment to hell with ways to install only the print driver without the need for graphical interfaces. It's possible that it can't be done, but if you blow up a virtual box it's no big loss. Or, you can follow the inevitable support forum advice and wait for a fix from the developers.

User avatar
Posts: 3043
Joined: 16 Feb 2015, 11:54

Re: Google WiFi

Post by Kellemora » 29 Sep 2016, 12:51

Hi Yogi

You didn't have to go through all of that. I probably should have deleted what I had written, once I figured out what the problem was.

I'll start here by saying I LOVE THIS NEW PRINTER! It is 100% functional in every way.
All the fancy stuff that Windows users normally have that Linux users do not, all work on Linux.
Normally, you are lucky just to find a fully functional print driver, and can forget any other feature of the printer.

As much as I hated giving HP any more of my money, eating crow and buying this printer was probably the best move I've made in a long time.
The Copy feature works perfect, the Scanner works on LInux without any of the problems I had with my other HP scanner on a Windows machine designed for that scanner. And talk about Printing, this thing spits out pages faster than you can grab them, hi hi... Double sided Copy to Print Double Sided is a little slower, but still amazingly fast.

Now you can laugh at me. After I got it up and running on USB, the install was easy on this computer, and after checking every feature and saw it worked great. Including the GUI options, service information, toner levels, etc.
Like I did with my Konica/Minolta, I went back after everything was working perfectly and plugged in the LAN and got it working from every computer in the house.
Then when I went to the GUI options panel, although the panel opened as it should, it did not show the printer state, or the toner levels any more.
I also checked the install on the Windows machine to find those GUI reports no longer work on Windows either. I wondered why since they worked on the Konica/Minolta OK.
A quick call to HP service said you cannot connect USB and LAN at the same time. I have to delete both the USB printer and the LAN printer, and then reinstall one or the other, but not both. However, I CAN leave both connected and print to USB from my computer, and use the LAN to access the printer from all the other computers, but the service module is disable if I do that.
I'm going to leave it the way it is, because the display panel on the printer itself, a nice size color touch screen gives all the information I need at the touch of a button.
Even though I can't use the GUI module to start projects directly as before, I can still open and use the optional features from the Applications drop down menu.

I needed 52 full color box labels printed, so I did 26 from the Windows machine, and 26 from the Silver Yogi, using the LAN printer connection. The Silver Yogi's 26 pages printed out 8 seconds faster than the Windows 26 pages.
Curiosity killed the cat, so I also printed another 26 labels using the USB printer. USB was 4 seconds faster than LAN.

This morning I played with the various scanner settings. On scanned photo's I keep, especially those which may need a touch up, I scan at the highest resolution possible. But for everyday scanning of items, I use a much lower setting. I was impressed with the quality of 75x75 fast scan, but still chose to do documents in 200x200. I compared them with documents I scanned on other scanners at 250x250 and this scanner looked sharper, so I am impressed.

Still going with curiosity. I had another copy of Debian 8.5 in a partition on the machine I run Linux Mint 17 on. After booting into Debian, the install on that machine went without a hitch also. Everything worked as it should. I then upgraded that machine to 8.6 to see if it would kill the install. It did not, everything worked exactly as it should.
So I think it is only the installer program itself that has to match the Distro release. By the way, 8.6 does use a newer kernel than 8.5, but apparently the printer drivers are in some type of file now the kernel looks for. This is good!

OK, I'll quit bending your eyeballs.

I'm very happy with this printer now! Glad I bought it!

Post Reply